summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ae82ff81dcf..658d3067cc25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=future-fstrings
pkgname=python-$_name
-pkgver=0.4.5
+pkgver=1.0.0
pkgrel=1
pkgdesc='A backport of fstrings to python<3.6'
arch=(any)
@@ -12,11 +12,18 @@ depends=(python)
_pyarch=py2.py3
_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
-sha256sums=('79c2f1b25d7c8d162d0a134471ec904090015122553742bb88c9ac1d60017136')
+sha256sums=('928aac9e1879a9fc49b8d873cae4638ce5a70673a79199a9e3b97c821a61de11')
noextract=("$_wheel")
package() {
local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
mkdir -p "$site"
unzip "$_wheel" -d "$site"
+
+ cat >future-fstrings-show.py <<-EOF
+ #!/usr/bin/env python3
+ from future_fstrings import main
+ main()
+ EOF
+ install -Dm755 future-fstrings-show.py "$pkgdir/usr/bin/future-fstrings-show"
}