summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 658d3067cc25..7c39a1ef852e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
_name=future-fstrings
pkgname=python-$_name
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='A backport of fstrings to python<3.6'
arch=(any)
url="https://github.com/asottile/$_name"
license=(MIT)
depends=(python)
+makedepends=(install-wheel-scripts)
_pyarch=py2.py3
_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
@@ -19,11 +20,5 @@ package() {
local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
mkdir -p "$site"
unzip "$_wheel" -d "$site"
-
- cat >future-fstrings-show.py <<-EOF
- #!/usr/bin/env python3
- from future_fstrings import main
- main()
- EOF
- install -Dm755 future-fstrings-show.py "$pkgdir/usr/bin/future-fstrings-show"
+ install-wheel-scripts --prefix="$pkgdir/usr" "$_wheel"
}