summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD73
1 files changed, 31 insertions, 42 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 22972d761ee0..f91fd7812954 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,38 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# Maintainer: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
-# Contributor: GalSim developers team on GitHub
-pkgname=python-galsim
-pkgver=1.5.0
+# Maintainer: knedl1k <knedl1k At tuta Dot io>
+# Contributor: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
+# Contributor: GalSim developers team on GitHub
+_base=GalSim
+pkgname=python-${_base,,}
+pkgver=2.5.2
pkgrel=1
-#epoch=
-
-pkgdesc=" The modular galaxy image simulation toolkit "
-
-
-arch=('x86_64')
-url="https://github.com/GalSim-developers/GalSim/releases/tag/v1.5.0-alpha"
-license=('unknown')
-groups=()
-depends=('python' 'scons' 'fftw' 'boost' 'tmv')
-makedepends=('git')
-checkdepends=()
-optdepends=()
-#provides=()
-#conflicts=()
-#replaces=()
-#backup=()
-options=()
-install=
-changelog=
-source=("https://github.com/GalSim-developers/GalSim/archive/v1.5.0-alpha.tar.gz")
-#noextract=()
-md5sums=('f74fd061510a1e507d6b9bc9f010e84c')
-#validpgpkeys=()
-
+pkgdesc="Modular galaxy image simulation toolkit"
+arch=(x86_64)
+url="https://github.com/${_base}-developers/${_base}"
+license=('BSD')
+depends=(python-astropy boost-libs eigen fftw python-coord python-future)
+makedepends=(python-build python-installer python-setuptools python-wheel pybind11 python-numpy)
+# checkdepends=(python-pytest) # python-timeout python-scipy python-yaml
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha256sums=('e6c04e2c983e241f3cd8a52de289a3ca8bf23c3ebbb692a96fbd27c84b427060')
build() {
- cd "$src"
- cd "GalSim-$pkgver-alpha"
- scons PREFIX=/usr TMV_DIR=/usr
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
+# check() {
+# cd ${_base}-${pkgver}
+# python -m venv --system-site-packages test-env
+# test-env/bin/python -m installer dist/*.whl
+# local _pyversion=$(python -c "import sys; print(f'{sys.version_info.major}{sys.version_info.minor}')")
+# LD_LIBRARY_PATH="$LD_LIBRARY_PATH:${srcdir}/${_base}-${pkgver}/build/lib.linux-${CARCH}-cpython-${_pyversion}/${_base,,}" test-env/bin/python -m pytest
+# }
package() {
- cd "$src"
- cd "GalSim-$pkgver-alpha"
- scons PREFIX=$pkgdir/usr install
-
-}
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+} \ No newline at end of file