summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c339b6676ed7..6e8ce70d17d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
_name=gaphor
pkgname=python-${_name}
-pkgver=2.24.0
-pkgrel=1
-pkgdesc="Simple and easy to use modeling tool for UML using GTK3"
+pkgver=2.25.1
+pkgrel=2
+pkgdesc="Simple and easy to use modeling tool for UML"
arch=('any')
url="https://github.com/gaphor/${_name}"
license=('Apache')
@@ -17,7 +17,6 @@ depends=(
'python-jedi'
'python-tinycss2'
'python-pygit2'
-# 'python-typing_extensions'
'python-better-exceptions'
'python-pydot'
'python-babel'
@@ -35,35 +34,41 @@ checkdepends=(
'python-pytest-archon'
'python-pytest-xvfb'
'python-sphinx'
-# 'python-babel-glade'
'python-xdoctest'
'xorg-server-xvfb'
+ 'python-pytest-randomly'
)
provides=("${_name}")
-source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('e20f32514c2db6c677206584087c908163f9bd348176b2cfe5dd04880f977e34')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz"
+ "${_name}.xml")
+sha256sums=('86a73972e90c448ecb08d32a374cbc465b58893a243501be5c8b97bd80df3f7a'
+ 'c3868ac8cb77749ef5a5afab722c67b6510f0bfe5a9e1da27ed06c3a8ab444a1')
build() {
cd "${_name}-${pkgver}"
- python po/build-babel.py
+ echo "Compiling translations ..."
+ python po/build-babel.py &> /dev/null
# Note: set `GIT_CEILING_DIRECTORIES` to prevent poetry
# from incorrectly using a parent git checkout info.
# https://github.com/pypa/build/issues/384#issuecomment-947675975
+ echo "Building wheel ..."
GIT_CEILING_DIRECTORIES="${PWD}/.." python -m build --wheel --no-isolation
}
check() {
cd "${srcdir}/${_name}-${pkgver}"
- python -m pytest -s tests
+ xvfb-run python -m pytest -s tests -p no:ruff -p no:mypy
+ #xvfb-run --auto-servernum python -m pytest -s tests
}
prepare() {
- gendesk -f -n --pkgname="$_name" --pkgdesc="$pkgdesc" --icon='org.gaphor.Gaphor' --categories='Development' PKGBUILD
+ gendesk -f -n --pkgname="$_name" --pkgdesc="$pkgdesc" --genericname="UML modelling tool" --mimetypes="application/x-gaphor" --icon='org.gaphor.Gaphor' --categories='Development' PKGBUILD
}
package() {
cd "${_name}-${pkgver}"
python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 "$srcdir/${_name}.xml" "${pkgdir}/usr/share/mime/packages/${pkgname}.xml"
install -Dm644 "$srcdir/${_name}.desktop" -t "$pkgdir"/usr/share/applications
install -Dm644 "$srcdir/${_name}-${pkgver}/data/logos/org.gaphor.Gaphor.svg" "$pkgdir"/usr/share/pixmaps/org.gaphor.Gaphor.svg
}