summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5337039f0106
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: GI_Jack <GI_Jack@hackermail.com>
+
+pkgname=python-gatt
+_pkgname=gatt
+pkgver=0.2.7
+pkgrel=1
+pkgdesc="Bluetooth GATT SDK for Python helps you implementing and communicating with any Bluetooth Low Energy device that has a GATT profile"
+url="https://github.com/getsenic/gatt-python"
+arch=('any')
+license=('GPLv3')
+depends=('python' 'bluez')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('626d9de24a178b6eaff78c31b0bd29f962681da7caf18eb20363f6288d014e3a')
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+}