summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7f5286b745f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Lucas H. Gabrielli <heitzmann@gmail.com>
+modname=gdspy
+pkgname=python-${modname}
+pkgver=0.7
+pkgrel=1
+pkgdesc="Gdspy is a Python module for creating GDSII stream files, usually CAD layouts."
+url="http://gdspy.sourceforge.net/"
+arch=('x86_64' 'i686')
+license=('GPL3')
+depends=('python' 'python-numpy')
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+install=
+source=("http://downloads.sourceforge.net/project/${modname}/${modname}/${modname}-${pkgver}/${modname}-${pkgver}.zip")
+md5sums=('8f69f47a27476e0f099f241d6bb12143')
+
+build() {
+ cd "${srcdir}/${modname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${modname}-${pkgver}"
+ python setup.py install --root=${pkgdir}
+}
+
+# vim:set ts=2 sw=2 et: