summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 24 insertions, 38 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18eb76af2e1e..adbb152ef0b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,31 @@
-# Maintainer: Clint Valentine <valentine.clint@gmail.com>
-
-_name=geneimpacts
-pkgbase='python-geneimpacts'
-pkgname=('python-geneimpacts' 'python2-geneimpacts')
-pkgver=0.3.4
+# Contributor: Clint Valentine <valentine.clint@gmail.com>
+_base=geneimpacts
+pkgname=python-${_base}
+pkgver=0.3.7
pkgrel=1
-pkgdesc="Compare and normalize effects from variant annotation tools (snpEff, VEP)"
-arch=('any')
-url="https://pypi.python.org/pypi/geneimpacts"
-license=('MIT')
-makedepends=(
- 'python' 'python-setuptools'
- 'python2' 'python2-setuptools')
-options=(!emptydirs)
-source=("${pkgname}"-"${pkgver}".tar.gz::https://pypi.python.org/packages/c9/0d/cdb5d3c45a65f33563d98838e89a6e37dad091cd10842a5c9f472503a8a3/geneimpacts-0.3.4.tar.gz)
-sha256sums=('bdd841977135ea81a75f2a58d7b9bce1a13682ca0c09eab18de42309257d893f')
-
-prepare() {
- cp -a "${_name}"-"${pkgver}"{,-py2}
-}
-
-build(){
- cd "${srcdir}"/"${_name}"-"${pkgver}"
+pkgdesc="normalize effects from variant annotation tools (snpEff, VEP)"
+arch=(any)
+url="https://pypi.org/project/${_base}"
+license=(MIT)
+depends=(python)
+makedepends=(python-setuptools)
+checkdepends=(python-nose)
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+sha512sums=('317f6f2122416266144d13d9e9a3623da9f15a6df85f2d329f2200389f9acfbc455ef2b9adf0ff335e3ca578ac013d8c9e49690f5e42466bea7641436dd5e0e4')
+
+build() {
+ cd ${_base}-${pkgver}
+ export PYTHONHASHSEED=0
python setup.py build
-
- cd "${srcdir}"/"${_name}"-"${pkgver}"-py2
- python2 setup.py build
}
-package_python2-geneimpacts() {
- depends=('python2')
-
- cd "${_name}"-"${pkgver}"-py2
- python2 setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
- install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+check() {
+ cd ${_base}-${pkgver}
+ python -m nose
}
-package_python-geneimpacts() {
- depends=('python')
-
- cd "${_name}"-"${pkgver}"
- python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
- install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+package() {
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}