summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 19 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c4380814da94..30eab68f6991 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,31 @@
+# Maintainer: Alexander Fasching <fasching.a91@gmail.com>
+# Contributor: Johannes Loethberg <johannes@kyriasis.com>
pkgname=python-geojson
-pkgver=2.4.0
+pkgver=2.5.0
pkgrel=1
-
-pkgdesc="Python bindings and utlities for GeoJSON"
+pkgdesc="Python bindings and utilities for GeoJSON"
url="https://github.com/frewsxcv/python-geojson"
arch=('any')
license=('BSD')
-
depends=('python')
makedepends=('python-setuptools')
-
source=(python-geojson-$pkgver.tar.gz::https://github.com/frewsxcv/python-geojson/archive/$pkgver.tar.gz)
+sha1sums=('e24040ec8efc582d2d3ef71b4e922ab5fe3b2bdd')
-sha1sums=('3d8203a2d673ed71548e13992459356dc2bd4ba8')
+build() {
+ cd geojson-$pkgver
+ python setup.py build
+}
+
+check() {
+ cd geojson-$pkgver
+ python setup.py test
+}
package() {
- cd python-geojson-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
- install -Dm644 LICENSE.rst "$pkgdir"/usr/share/licenses/python-geojson/LICENSE
+ cd geojson-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE.rst "$pkgdir"/usr/share/licenses/python-geojson/LICENSE
}
+
+# vim:set sw=2 et: