summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3761f56e97bd..3e6a4e55ab13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,26 +8,33 @@ pkgdesc="Simple, concise geographical visualization in Python"
arch=(any)
url="https://github.com/pyviz/${_base}"
license=('custom:BSD-3-clause')
-depends=(python-bokeh python-cartopy python-holoviews python-packaging python-xarray)
-makedepends=(nodejs)
+depends=(python-cartopy python-holoviews)
+makedepends=(python-build python-installer python-setuptools python-wheel npm)
+checkdepends=(python-pytest python-geopandas python-spatialpandas) # python-nbsmoke python-xarray
# optdepends=('python-datashader: for '
# 'python-geopandas: for '
# 'python-osgeo: for ' # gdal
# 'jupyter-notebook: for '
# 'python-matplotlib: for '
# )
-checkdepends=(python-pytest) # python-nbsmoke
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
sha512sums=('a1e199a37cbc19dc6756130b891b2388f4a4a1176df507e83af0b00d8b0edd50019f278173fdb553f5370cdd86fffb175cb8201e4aa098038960d14b9658f3a9')
build() {
cd ${_base}-${pkgver}
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
+
+check() {
+ cd ${_base}-${pkgver}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest ${_base}/tests
}
package_python-geoviews() {
cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
}