summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 23 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 35732456a12c..f276edc738e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,41 @@
# Maintainer: jerry73204 <jerry73204 at google gmail>
pkgname='python-geoviews'
-pkgver=1.6.2
-pkgrel=2
+pkgver=1.8.1
+pkgrel=1
pkgdesc='Simple, concise geographical visualization in Python'
arch=('any')
url='https://github.com/pyviz/geoviews'
license=('BSD')
makedepends=('python-setuptools'
'python-param')
-depends=('python-bokeh'
- 'python-cartopy'
- 'python-holoviews'
- 'python-numpy'
- 'python-param')
-optdepends=('python-datashader'
- 'python-geopandas'
- 'python-netcdf4'
- 'python-gdal'
- 'python-matplotlib>2.2'
- 'python-pandas'
- 'python-pyct'
- 'python-scipy'
- 'python-shapely'
- 'python-xarray'
- 'jupyter')
+depends=(
+ 'python-bokeh'
+ 'python-cartopy'
+ 'python-holoviews'
+ 'python-numpy'
+ 'python-param'
+)
+optdepends=(
+ 'python-datashader'
+ 'python-geopandas'
+ 'python-netcdf4'
+ 'python-gdal'
+ 'python-matplotlib>2.2'
+ 'python-pandas'
+ 'python-pyct'
+ 'python-scipy'
+ 'python-shapely'
+ 'python-xarray'
+ 'jupyter'
+)
checkdepends=('python-pytest'
'python-coveralls'
'python-nose'
# 'python-nbsmoke' # This package is missing
'flake8')
source=("https://github.com/pyviz/geoviews/archive/v${pkgver}.tar.gz")
-sha256sums=('b89c44168891fff3071e38a671a8f7806179a60733dbedc2a32143ebabc2b974')
-
+sha256sums=('c71a3203a47dbff1e17af590c854bd2c44157f077b1d37589404e89238050b1f')
build() {
cd "${srcdir}/geoviews-${pkgver}"
python setup.py build