summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD68
1 files changed, 26 insertions, 42 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f276edc738e5..696d5f98d963 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,33 @@
-# Maintainer: jerry73204 <jerry73204 at google gmail>
-
-pkgname='python-geoviews'
-pkgver=1.8.1
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: jerry73204 <jerry73204 at google gmail>
+_base=geoviews
+pkgname=python-${_base}
+pkgver=1.9.5
pkgrel=1
-pkgdesc='Simple, concise geographical visualization in Python'
-arch=('any')
-url='https://github.com/pyviz/geoviews'
-license=('BSD')
-makedepends=('python-setuptools'
- 'python-param')
-depends=(
- 'python-bokeh'
- 'python-cartopy'
- 'python-holoviews'
- 'python-numpy'
- 'python-param'
-)
-optdepends=(
- 'python-datashader'
- 'python-geopandas'
- 'python-netcdf4'
- 'python-gdal'
- 'python-matplotlib>2.2'
- 'python-pandas'
- 'python-pyct'
- 'python-scipy'
- 'python-shapely'
- 'python-xarray'
- 'jupyter'
-)
-checkdepends=('python-pytest'
- 'python-coveralls'
- 'python-nose'
- # 'python-nbsmoke' # This package is missing
- 'flake8')
-source=("https://github.com/pyviz/geoviews/archive/v${pkgver}.tar.gz")
-sha256sums=('c71a3203a47dbff1e17af590c854bd2c44157f077b1d37589404e89238050b1f')
+pkgdesc="Simple, concise geographical visualization in Python"
+arch=(any)
+url="https://github.com/pyviz/${_base}"
+license=('custom:BSD-3-clause')
+depends=(python-bokeh python-cartopy python-holoviews python-packaging python-xarray)
+makedepends=(nodejs)
+# optdepends=('python-datashader: for '
+# 'python-geopandas: for '
+# 'python-osgeo: for ' # gdal
+# 'jupyter-notebook: for '
+# 'python-matplotlib: for '
+# )
+checkdepends=(python-pytest) # python-nbsmoke
+source=(${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('8cc4d468b7c043ba9a512c581c093b460f920eec0cb3cd67f2770b714a22f94762044eb2813a4660d3303d6331e3294918cc9f3670d533e3d92a091af380da30')
+
build() {
- cd "${srcdir}/geoviews-${pkgver}"
+ cd ${_base}-${pkgver}
python setup.py build
}
package_python-geoviews() {
- cd "${srcdir}/geoviews-$pkgver"
- python setup.py install --skip-build --prefix=/usr --root="${pkgdir}" --optimize=1
- install -D -m644 LICENSE* "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -D -m644 README* "${pkgdir}/usr/share/doc/${pkgname}/README"
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
}