summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 15 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30fb14fb87fa..e7f5fe2c86fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,30 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
-_modulename=getdist
-pkgname=python-$_modulename
-pkgver=1.0.0
+pkgname=python-getdist
+_name=GetDist
+pkgver=1.4.3
pkgrel=1
pkgdesc="MCMC sample analysis, kernel densities, plotting, and GUI"
arch=(any)
-url="https://github.com/cmbant/getdist"
+url="https://github.com/cmbant/$_name"
license=()
groups=()
-depends=('python-numpy' 'python-matplotlib' 'python-six' 'python-scipy' 'python-pyside' 'python-pandas')
-makedepends=('python-setuptools')
+depends=(python-numpy python-matplotlib python-six python-scipy pyside2 python-pandas)
+makedepends=(python-setuptools)
provides=()
conflicts=()
replaces=()
backup=()
options=(!emptydirs)
install=
-source=("${url}/archive/${pkgver}.tar.gz")
-sha256sums=('d0219e77cff599b10c6b26c4008b0b0f7d7d101a8a8efdb41b63fccd265b9025')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('7432945e2d517c6ba765348eff276c0affb2da2b69397b1a99c743ee57666180')
-package() {
- cd "$srcdir/$_modulename-${pkgver}"
- python setup.py install --root="$pkgdir/" --optimize=1
- mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python -m build --wheel --no-isolation
}
-check() {
- cd "$srcdir/$_modulename-${pkgver}"
- python setup.py test
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}