summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e6c9a47b425..0f8cf68b6f92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
_pkgname=getdist
pkgname=python-$_pkgname-git
-pkgver=r112.de5e238
-pkgrel=3
+pkgver=r318.9949a14
+pkgrel=1
pkgdesc="MCMC sample analysis, kernel densities, plotting, and GUI"
-arch=('any')
+arch=(any)
url="https://github.com/cmbant/getdist"
license=()
groups=()
-depends=('python-numpy' 'python-matplotlib' 'python-six' 'python-scipy' 'python-pyside' 'python-pandas')
-makedepends=('git' 'python-setuptools')
+depends=(python-numpy python-matplotlib python-six python-scipy pyside2 python-pandas)
+makedepends=(git python-setuptools)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
replaces=()
@@ -18,14 +18,19 @@ options=()
install=
source=("${pkgname%-git}::git+$url.git")
noextract=()
-md5sums=('SKIP')
+md5sums=(SKIP)
pkgver() {
cd "$srcdir/${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "$srcdir/${pkgname%-git}"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$srcdir/${pkgname%-git}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}