summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD84
1 files changed, 29 insertions, 55 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d8ff5880129..5c0c53a31828 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,67 +1,41 @@
-# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Clint Valentine <valentine.clint@gmail.com>
-_name=gffutils
-pkgbase='python-gffutils'
-pkgname=('python-gffutils' 'python2-gffutils')
-pkgver=0.9
-pkgrel=3
+pkgname=python-gffutils
+pkgver=0.10.1
+pkgrel=1
pkgdesc="GFF and GTF file manipulation and interconversion in Python"
arch=('any')
-url="https://pypi.python.org/pypi/gffutils"
+url="https://github.com/daler/gffutils"
license=('MIT')
-makedepends=(
- 'python' 'python-setuptools'
- 'python2' 'python2-setuptools')
-options=(!emptydirs)
-source=("${pkgname}"-"${pkgver}".tar.gz::https://pypi.python.org/packages/b4/ea/54ca403a8d471849606fb432b9afcf73c8c5105ea2dd87b8d38bd5217c5a/gffutils-0.9.tar.gz)
-sha256sums=('e1b0bf2b422ec3491be13d77bf7baf71d274abd844e8f8b6c1217a95b236218b')
+depends=(
+ 'python-argcomplete'
+ 'python-argh'
+ 'python-pyfaidx'
+ 'python-simplejson'
+ 'python-six')
+optdepends=(
+ 'bedtools: for genomic interval arithemtic'
+ 'python-biopython: for sequence manipulation'
+ 'python-pybedtools: wrapper for bedtools')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+ '001-setup.py.patch')
+sha256sums=('c020f38d572a38227d575ca6b4a6781e10317c4231c7008f533bb6d9167f64d8'
+ '8b8b8e89a6cf1cd74f73f5e5a67053a24bcc681182bc20c30716818fe9243c58')
prepare() {
- cp -a "${_name}"-"${pkgver}"{,-py2}
+ patch -p1 -d "gffutils-$pkgver" < 001-setup.py.patch
+ sed -i "s/@PKGVER@/$pkgver/" "gffutils-$pkgver/setup.py"
}
build(){
- cd "${srcdir}"/"${_name}"-"${pkgver}"
- python setup.py build
-
- cd "${srcdir}"/"${_name}"-"${pkgver}"-py2
- python2 setup.py build
-}
-
-package_python2-gffutils() {
- depends=(
- 'python2'
- 'python2-argcomplete'
- 'python2-argh'
- 'python2-pyfaidx'
- 'python2-simplejson'
- 'python2-six')
- optdepends=(
- 'bedtools: for genomic interval arithemtic'
- 'python2-biopython: for sequence manipulation'
- 'python2-pybedtools: wrapper for bedtools')
-
- cd "${_name}"-"${pkgver}"-py2
- python2 setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
- install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
-
- mv "${pkgdir}"/usr/bin/"${_name}"-cli "${pkgdir}"/usr/bin/"${_name}"-cli2
+ cd "gffutils-$pkgver"
+ python setup.py build
}
-package_python-gffutils() {
- depends=(
- 'python'
- 'python-argcomplete'
- 'python-argh'
- 'python-pyfaidx'
- 'python-simplejson'
- 'python-six')
- optdepends=(
- 'bedtools: for genomic interval arithemtic'
- 'python-biopython: for sequence manipulation'
- 'python-pybedtools: wrapper for bedtools')
-
- cd "${_name}"-"${pkgver}"
- python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
- install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+package() {
+ cd "gffutils-$pkgver"
+ PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}