summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47c5ad7d3198
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Miguel de Val-Borro <miguel at archlinux dot net>
+
+pkgname=python-ginga
+pkgver=2.6.2
+pkgrel=1
+pkgdesc=" A viewer for astronomical data FITS (Flexible Image Transport System) files."
+arch=('i686' 'x86_64')
+url="http://ejeschke.github.io/ginga/"
+license=('BSD')
+depends=('python'
+ 'python-astropy'
+ 'python-astropy-helpers'
+ 'python-matplotlib'
+ 'python-scipy')
+source=("https://files.pythonhosted.org/packages/source/g/ginga/ginga-${pkgver}.tar.gz")
+md5sums=('a98559abd5532d41a7e6bd243bf9c1f3')
+
+package(){
+ cd $srcdir/ginga
+ python setup.py install --root="$pkgdir/" --optimize=1 --use-system-libraries
+}