summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b34c1af3b0b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Morten Linderud <morten@linderud.pw>
+_pkgname='giturlparse.py'
+pkgbase="python-giturlparse"
+pkgname=("python-giturlparse" "python2-giturlparse")
+pkgver=0.0.5
+pkgrel=1
+pkgdesc='Parse & rewrite git urls (supports GitHub, Bitbucket, Assembla ...)'
+url='https://github.com/FriendCode/giturlparse.py'
+arch=('any')
+license=('Apache')
+makedepends=('python' 'python-setuptools'
+ 'python2' 'python2-setuptools')
+source=("${pkgbase}-${pkgver}.tar.gz::https://github.com/FriendCode/giturlparse.py/archive/${pkgver}.tar.gz")
+sha256sums=('91e398db31d295ba75b25b74a80835e2e24d6bdb818201aa58169833551745ca')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+ python2 setup.py build
+}
+
+package_python-giturlparse() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+
+package_python2-giturlparse() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+# vim:set ft=sh ts=2 sw=2 et: