summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d61627d41c8..823d4e45f984 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
-pkgname=('python-glyphslib')
-_pkgname='glyphsLib'
-pkgver='5.0.1'
+pkgname=python-glyphslib
+_pkgname=glyphsLib
+pkgver='5.1.7'
pkgrel=1
pkgdesc="A bridge from Glyphs source files (.glyphs) to UFOs"
url="https://github.com/googlefonts/glyphsLib"
-checkdepends=('python-pytest' 'python-ufonormalizer' 'python-unicodedata2=12.0.0' 'python-xmldiff')
+checkdepends=('python>=3.8' 'python-pytest' 'python-ufonormalizer' 'python-xmldiff')
depends=('python' 'python-defcon' 'python-fonttools')
makedepends=('python-setuptools')
optdepends=('python-ufonormalizer')
license=('Apache')
arch=('any')
source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip")
-sha256sums=('424402e3e4405f5aa6f1b88699f12f636cad9225ddcfd05624cf4f55aaa62cd6')
+sha256sums=('dfa2baf89c7418cea410b049ef95251a5256bc366ca62eef7271ee7ecf2ea602')
-#check() {
- #cd "$srcdir/$_pkgname-$pkgver"
- #python setup.py test
-#}
+check() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ PYTHONPATH=Lib pytest
+}
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"