summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 7 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 179803077372..8462c32c3f8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
# Maintainer: Ainola
# Contributor: Felix Yan <felixonmars@archlinux.org> (Stable Package)
-pkgbase=python-google-auth-httplib2-git
-pkgname=(python-google-auth-httplib2-git python2-google-auth-httplib2-git)
+pkgname=python-google-auth-httplib2-git
pkgver=r8.e7cd722
-pkgrel=3
+pkgrel=4
pkgdesc="Google Authentication Library: httplib2 transport"
url="https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2"
license=('Apache')
arch=('any')
-makedepends=('python-setuptools' 'python2-setuptools' 'python-google-auth' 'python2-google-auth'
- 'python-httplib2' 'python2-httplib2' 'python-six' 'python2-six' 'git')
-checkdepends=('python-pytest-runner' 'python2-pytest-runner' 'python-mock' 'python2-mock'
- 'python-flask' 'python2-flask' 'python-pytest-localserver'
- 'python2-pytest-localserver')
+depends=('python-google-auth' 'python-httplib2' 'python-six')
+provides=('python-google-auth-httplib2')
+conflicts=('python-google-auth-httplib2')
+makedepends=('python-setuptools' 'git')
+checkdepends=('python-pytest-runner' 'python-mock' 'python-flask' 'python-pytest-localserver')
source=("git+https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2.git")
sha512sums=('SKIP')
@@ -22,43 +21,18 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cp -a google-auth-library-python-httplib2{,-py2}
-}
-
build() {
cd google-auth-library-python-httplib2
python setup.py build
-
- cd "$srcdir/google-auth-library-python-httplib2-py2"
- python2 setup.py build
}
check() {
cd google-auth-library-python-httplib2
python setup.py pytest
-
- cd ../google-auth-library-python-httplib2-py2
- python2 setup.py pytest
}
package_python-google-auth-httplib2-git() {
- depends=('python-google-auth' 'python-httplib2' 'python-six')
- provides=('python-google-auth-httplib2')
- conflicts=('python-google-auth-httplib2')
-
cd google-auth-library-python-httplib2
python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-package_python2-google-auth-httplib2-git() {
- depends=('python2-google-auth' 'python2-httplib2' 'python2-six')
- provides=('python-google-auth-httplib2')
- conflicts=('python-google-auth-httplib2')
-
- cd google-auth-library-python-httplib2-py2
- python2 setup.py install --root="$pkgdir" --optimize=1
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-}
-