summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 20 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bed312b3c386..467bf2bea83b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,58 +2,59 @@
# Contributor: Kaizhao Zhang <zhangkaizhao@gmail.com>
pkgname=python-google-cloud-bigquery
+_pkgname="${pkgname#python-}"
_pkg=python-bigquery
-pkgver=3.3.0
+pkgver=3.4.1
pkgrel=1
pkgdesc="Google BigQuery API client library"
arch=('any')
url="https://github.com/googleapis/python-bigquery"
license=('Apache')
depends=(
- 'python-pyarrow'
'python-dateutil'
'python-google-api-core'
- 'python-google-cloud-core'
'python-google-cloud-bigquery-storage'
+ 'python-google-cloud-core'
'python-google-resumable-media'
'python-grpcio'
'python-packaging'
'python-protobuf'
+ 'python-pyarrow'
'python-requests')
makedepends=(
- 'python-setuptools'
+ 'ipython'
'python-build'
'python-installer'
- 'python-wheel'
- 'python-sphinx'
'python-recommonmark'
- 'ipython')
+ 'python-setuptools'
+ 'python-sphinx'
+ 'python-wheel')
optdepends=(
'ipython'
- 'python-pandas: pandas support'
- 'python-tqdm: tqdm support'
'python-fastparquet: fastparquet support'
+ 'python-llvmlite: fastparquet support'
+ 'python-pandas: pandas support'
'python-snappy: fastparquet support'
- 'python-llvmlite: fastparquet support')
+ 'python-tqdm: tqdm support')
changelog=CHANGELOG.md
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('9eb15a14b8b0f9768402ef042d2971466449f0c79313a57769dca5f4c1874635')
+# source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/g/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('884689714d98a2364dde9c7c367e8228c7116108bbad7a6365dfde391638985b')
build() {
- cd "$_pkg-$pkgver"
+ cd "$_pkgname-$pkgver"
python -m build --wheel --no-isolation
# PYTHONPATH="$PWD" sphinx-build -b man docs/ _build
}
package() {
- export PYTHONHASHSEED=0
- cd "$_pkg-$pkgver"
+ cd "$_pkgname-$pkgver"
python -m installer --destdir="$pkgdir/" dist/*.whl
- install -Dm644 README.rst -t "$pkgdir/usr/share/doc/$pkgname/"
+ install -Dvm644 README.rst -t "$pkgdir/usr/share/doc/$pkgname/"
# install -Dm644 _build/google-cloud-bigquery.1 -t "$pkgdir/usr/share/man/man1/"
local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
- install -d "$pkgdir/usr/share/licenses/$pkgname/"
- ln -s \
- "$_site/google_cloud_bigquery-$pkgver.dist-info/LICENSE" \
+ install -dv "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -sv \
+ "$_site/${_pkgname//-/_}-$pkgver.dist-info/LICENSE" \
"$pkgdir/usr/share/licenses/$pkgname/"
}