summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06b079b12ae0..95a868a76368 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,28 @@
-# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+# Maintainer: Aseem Athale <athaleaseem@gmail.com>
+# Contributor: Grey Christoforo <first name [at] last name [dot] net>
pkgname=python-google-cloud-firestore
-pkgver=1.9.0
+pkgver=2.12.0
pkgrel=1
pkgdesc="Google's Firestore Python client library"
arch=(x86_64)
url=https://github.com/googleapis/python-firestore
license=(APACHE)
depends=('python')
-makedepends=(python-setuptools)
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
source=(https://github.com/googleapis/python-firestore/archive/v${pkgver}.tar.gz)
-sha256sums=('889ea0f4a8926c796f055627f12db96c4d29632159eff5b7032cfecd23283093')
-
-prepare() {
- cd "python-firestore-$pkgver"
- #versioneer install
-}
+sha256sums=('9f44566b6b29dc45095c53d3fb49ce267aa799726a427ab6a1ff3942873ab092')
build() {
cd "python-firestore-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "python-firestore-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim:ts=2:sw=2:et: