summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 07454043219b..0ec30e7c059d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
-# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
+# Contributor: Kaizhao Zhang <zhangkaizhao@gmail.com>
pkgname=python-google-crc32c
_name="${pkgname/-google/}"
pkgver=1.2.0
-pkgrel=1
-pkgdesc="Wraps Google's CRC32C library into a Python wrapper"
-arch=('any')
+pkgrel=2
+pkgdesc="Wraps Google's crc32c library into a Python wrapper"
+arch=('x86_64')
url="https://github.com/googleapis/python-crc32c"
license=('APACHE')
-depends=('python>=3.6')
-optdepends=('google-crc32c: use C extension instead of pure Python implementation (requires rebuild)')
+depends=('python>=3.6' 'google-crc32c')
makedepends=('python-setuptools')
checkdepends=('python-pytest')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
@@ -31,5 +30,5 @@ check() {
package() {
cd "$_name-$pkgver"
PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm644 README.md SECURITY.md "$pkgdir/usr/share/doc/$pkgname/README.md"
}