summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15a18f859e38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=python-google-pasta
+pkgver=0.2.0
+pkgrel=1
+pkgdesc='Library to refactor python code through AST manipulation'
+arch=('any')
+url='https://github.com/google/pasta'
+license=('Apache')
+depends=('python-six')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/google/pasta/archive/v${pkgver}.tar.gz")
+sha256sums=('b9e3bcf5ab79986e245c8a2f3a872d14c610ce66904c4f16818342ce81cf97d2')
+
+package() {
+ cd "pasta-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+} \ No newline at end of file