summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b61df3c49e00..1eb6bce442ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,35 @@
-# Maintainer: Mufeed Ali <fushinari@protonmail.com>
+# Maintainer: Sam L. Yes <samlukeyes123 at gmail dot com>
+# Contributor: Mufeed Ali <fushinari@protonmail.com>
pkgname=python-googletrans-git
_author=ssut
_gitname=py-googletrans
-pkgver=0.r115.4f7c079
+pkgver=r116.d15c94f
pkgrel=1
pkgdesc="Free Google Translate API for Python. Git version."
arch=('any')
license=('MIT')
url="https://github.com/ssut/py-googletrans"
depends=(
- python-setuptools
python-httpx
)
+makedepends=(
+ python-setuptools
+ git
+)
provides=('python-googletrans')
conflicts=('python-googletrans')
source=("git+https://github.com/$_author/$_gitname.git")
sha512sums=('SKIP')
+prepare() {
+ cd ${srcdir}/$_gitname
+ sed -i 's|httpx==|httpx>=|' setup.py
+}
+
pkgver() {
cd "$_gitname"
- printf '0.r%s.%s' \
+ printf 'r%s.%s' \
"$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
@@ -32,5 +41,6 @@ build() {
package() {
cd "$_gitname"
python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}