summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51bdd3421508..8d903399b694 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,27 @@
pkgname=python-gps3
_name=${pkgname#python-}
pkgver=0.33.3
-pkgrel=1
+pkgrel=2
pkgdesc="Python GPSD interface"
arch=('any')
url="https://github.com/wadda/gps3"
license=('MIT')
depends=('python')
makedepends=('python-pip')
-install="$_name.install"
source=("https://files.pythonhosted.org/packages/20/c1/9548cb5388a85e31557d1f1f66e2ad0b269d8aeb982f34f72f83d9bdbaeb/$_name-$pkgver-py2.py3-none-any.whl"
"https://github.com/wadda/gps3/raw/master/LICENSE")
sha256sums=('9c7ef9fa334ae6d4157fa63abe6df334d4f0878dbb628d10cb4c5f304eb22978'
'79b976c5c314ca8828c95deb8a2c9cc28f1c93b0c74f4e6dd1dbe0ff8b972288')
-
package() {
- PIP_CONFIG_FILE=/dev/null pip install \
- --isolated \
- --root="$pkgdir" \
- --ignore-installed \
- --no-deps *.whl
+ PIP_CONFIG_FILE=/dev/null pip install \
+ --isolated \
+ --root="$pkgdir" \
+ --ignore-installed \
+ --no-deps *.whl
+
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ python -O -m compileall "$pkgdir$site_packages/$_name"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}