summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 595fadbded13..bbc3d494a309 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-gpy
pkgver=1.9.2
-pkgrel=1
+pkgrel=2
pkgdesc="Gaussian processes framework in python"
arch=("any")
license=("BSD")
@@ -14,6 +14,13 @@ makedepends=('python-setuptools' 'python-numpy')
source=("https://github.com/SheffieldML/GPy/archive/v${pkgver}.tar.gz")
sha512sums=("50dc3627a05b9fc2fbc61204cf492e89d5c067da7aca3e738c52cc3c06652aa825e27e66b0a14a2e67e074cd19a75ab564449a762f1de1ba27a02fc986432403")
+prepare() {
+ cd "GPy-${pkgver}"
+
+ # Forcibly update cython for python 3.7
+ find . -name '*.pyx' -exec cython {} \;
+}
+
build() {
cd "GPy-${pkgver}"
python setup.py build