summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 9 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 679879c28003..c286cd76d3c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,18 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=python-gpytorch
-pkgver=1.8.1
+pkgver=1.9.0
pkgrel=1
pkgdesc='A highly efficient and modular implementation of GPs, with GPU
acceleration. Implemented in PyTorch.'
arch=('x86_64')
url='https://gpytorch.ai'
license=('MIT')
-depends=('python' 'python-pytorch' 'python-numpy' 'python-scikit-learn' 'python-scipy')
-makedepends=('python' 'python-build' 'python-installer' 'python-wheel' 'python-setuptools')
+depends=('python' 'python-scikit-learn' 'python-linear-operator' 'python-pytorch')
+makedepends=('git' 'python' 'python-build' 'python-installer' 'python-wheel'
+ 'python-setuptools' 'python-setuptools-scm')
optdepends=(
- 'python-black: for [dev] module'
- 'twine: for [dev] module'
- 'python-pre-commit: for [dev] module'
- 'ipython: for [docs/examples] module'
- 'python-ipykernel: for [docs] module'
- 'python-sphinx: for [docs] module'
- 'python-sphinx_rtd_theme: for [docs] module'
- 'python-nbsphinx: for [docs] module'
- 'm2r: for [docs] module'
+ 'ipython: for [examples] module'
'jupyter: for [examples] module'
'python-matplotlib: for [examples] module'
'python-scipy: for [examples] module'
@@ -27,22 +20,16 @@ optdepends=(
'python-tqdm: for [examples] module'
'python-pyro-ppl: for [pyro] module'
'python-pykeops: for [keops] module'
- 'python-flake8: for [test] module'
- 'python-flake8-print: for [test] module'
- 'python-pytest: for [test] module'
- 'python-nbval: for [test] module'
)
-source=("$pkgname-$pkgver::https://github.com/cornellius-gp/gpytorch/archive/v$pkgver.tar.gz")
-sha256sums=('be1bcbc2d8db835e145d710ba7520ab0c5907fe0e28a08c9d7ac76ae8e4f1f7c')
-
-_pkgname=gpytorch
+source=("$pkgname-$pkgver::git+https://github.com/cornellius-gp/gpytorch.git#tag=v$pkgver")
+sha256sums=('SKIP')
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python -m installer --destdir="$pkgdir" dist/*.whl
}