summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0ed558b6b92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+
+pkgname=python-gpytorch
+pkgver=0.3.5
+pkgrel=1
+pkgdesc='A highly efficient and modular implementation of GPs, with GPU
+acceleration. Implemented in PyTorch.'
+arch=('x86_64')
+url='https://gpytorch.ai'
+license=('MIT')
+depends=('python' 'python-pytorch')
+optdepends=()
+makedepends=('python' 'python-setuptools')
+source=("$pkgname-$pkgver::https://github.com/cornellius-gp/gpytorch/archive/v$pkgver.tar.gz")
+sha256sums=('904eecd5c5d88fa98f95e34b3ee53f94706fc7d6c3adc164c4e90a007e72d41b')
+
+_pkgname=gpytorch
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir"/ --optimize=1
+}