summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 23 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68daa6a48659..0a7cbd8b0f47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,36 @@
pkgname=python-gpytorch
pkgver=1.1.1
-pkgrel=1
+pkgrel=2
pkgdesc='A highly efficient and modular implementation of GPs, with GPU
acceleration. Implemented in PyTorch.'
arch=('x86_64')
url='https://gpytorch.ai'
license=('MIT')
depends=('python' 'python-pytorch')
-optdepends=()
makedepends=('python' 'python-setuptools')
+optdepends=(
+ 'python-black: for [dev] module'
+ 'twine: for [dev] module'
+ 'python-pre-commit: for [dev] module'
+ 'ipython: for [docs/examples] module'
+ 'python-ipykernel: for [docs] module'
+ 'python-sphinx: for [docs] module'
+ 'python-sphinx_rtd_theme: for [docs] module'
+ 'python-nbsphinx: for [docs] module'
+ 'm2r: for [docs] module'
+ 'jupyter: for [examples] module'
+ 'python-matplotlib: for [examples] module'
+ 'python-scipy: for [examples] module'
+ 'python-torchvision: for [examples] module'
+ 'python-tqdm: for [examples] module'
+ 'python-pyro-ppl: for [pyro] module'
+ 'python-pykeops: for [keops] module'
+ 'python-flake8: for [test] module'
+ 'python-flake8-print: for [test] module'
+ 'python-pytest: for [test] module'
+ 'python-nbval: for [test] module'
+ )
source=("$pkgname-$pkgver::https://github.com/cornellius-gp/gpytorch/archive/v$pkgver.tar.gz")
sha256sums=('8ef20659e3a077554a3582554ee39e4bed3b95902dfd4cac693328c387e2899c')