summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c4d69a728baa..ad54c3e228c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=python-grandalf
_pkgname=${pkgname#python-}
pkgver=0.8
-pkgrel=1
+pkgrel=2
pkgdesc='graph and drawing algorithms framework'
arch=(any)
url="https://github.com/bdcht/$_pkgname"
@@ -14,11 +14,16 @@ depends=(python
makedepends=(python-{build,installer,wheel}
python-setuptools)
checkdepends=(python-pytest
- python-pytest-runner)
+ python-pytest)
_archive="$_pkgname-$pkgver"
source=("$url/archive/v$pkgver/$_archive.tar.gz")
sha256sums=('82d80072e5a1928bc46d94a54d2d92a38f73da0af052efc84ce34b5f4601dfa2')
+prepare() {
+ cd "$_archive"
+ sed -i -e '/setup_requires/d' setup.py
+}
+
build() {
cd "$_archive"
python -m build -wn
@@ -26,7 +31,8 @@ build() {
check() {
cd "$_archive"
- python -m pytest
+ export PYTHONPATH="$PWD/build/lib"
+ pytest
}
package() {