summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 756bfb8b3ad6..206e706e0b5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
-# Maintainer: Aleksandar Trifunović <akstrfn at gmail dot com>
-# Contributor: Tiago de Paula Peixoto <tiago@skewed.de>
+# Maintainer: Tiago de Paula Peixoto <tiago@skewed.de>
_pkgname=python-graph-tool
pkgname=python-graph-tool-git
-pkgver=2.27.r7.g41bae98c
+pkgver=99
pkgrel=1
pkgdesc='A Python module for manipulation and statistical analysis of graphs'
arch=('i686' 'x86_64')
url='https://graph-tool.skewed.de'
license=(GPL3)
-depends=(cgal cairomm python-scipy python-numpy python-cairo)
+depends=(boost-libs python expat python-scipy python-numpy cgal cairomm-1.16 python-cairo python-zstandard python-gobject)
makedepends=(boost sparsehash autoconf-archive)
optdepends=('graphviz: graph layout'
'python-matplotlib: graph drawing')
@@ -28,6 +27,9 @@ pkgver() {
build() {
cd "$pkgname"
./autogen.sh
+ # disable assertions which lead to runtime performance degradation
+ CXXFLAGS=${CXXFLAGS/-Wp,-D_GLIBCXX_ASSERTIONS/}
+ export CXXFLAGS="$CXXFLAGS -O3 -march=native -flto=auto -fno-fat-lto-objects"
./configure --enable-openmp --prefix=/usr --docdir="/usr/share/doc/$_pkgname"
make -j 1 # most users will be surprised with the high memory usage required for parallel builds
}