summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9f8b6f6dd19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Joseph Lansdowne <J49137@gmail.com>
+_pkgname=gw2buildutil
+pkgname=python-$_pkgname
+pkgver=0.1
+pkgrel=1
+pkgdesc="Python 3 library for working with Guild Wars 2 builds"
+arch=(any)
+url=http://ikn.org.uk/lib/gw2buildutil
+license=(BSD)
+makedepends=(python-setuptools)
+depends=("python>=3.7")
+source=("http://ikn.org.uk/download/lib/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha1sums=('06daf098b1d65a06118b5cffd0eb834b40cbc37a')
+
+build () {
+ cd "$srcdir/${_pkgname}-$pkgver"
+ make
+}
+
+package () {
+ cd "$srcdir/${_pkgname}-$pkgver"
+ make DESTDIR="$pkgdir" prefix=/usr install
+ install -D LICENSE "$pkgdir"/usr/share/licenses/"$_pkgname"/LICENSE
+}