summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c256653c7a0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: richli <rich at dranek dot com>
+
+pkgname=python-h5netcdf
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="Pythonic interface to netCDF4 via h5py"
+arch=('any')
+url="https://github.com/shoyer/h5netcdf"
+license=('BSD')
+depends=('python-h5py')
+makedepends=('python-setuptools')
+checkdepends=('python-netcdf4' 'python-pytest')
+source=(https://github.com/shoyer/h5netcdf/archive/v${pkgver}.tar.gz)
+md5sums=('4ad00f60c88aae29a6640f030d0ef41e')
+
+build() {
+ cd "$srcdir/h5netcdf-${pkgver}"
+ python setup.py build
+}
+
+check() {
+ cd "$srcdir/h5netcdf-${pkgver}"
+ PYTHONPATH="./build/lib" py.test -v
+}
+
+package() {
+ cd "$srcdir/h5netcdf-${pkgver}"
+ python setup.py install --prefix=/usr --root="$pkgdir" --skip-build --optimize 2
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: set et sw=4 ts=4 sts=4: