summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aec4877d157c..58dd4a88bf27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: richli <rich at dranek dot com>
pkgname=python-h5netcdf
-pkgver=0.12.0
+pkgver=0.13.0
pkgrel=1
pkgdesc="Pythonic interface to netCDF4 via h5py"
arch=('any')
@@ -11,25 +11,27 @@ license=('BSD')
depends=('python-h5py')
makedepends=('python-setuptools')
checkdepends=('python-netcdf4' 'python-pytest')
+
+_pypi=h5netcdf
source=(
- "https://files.pythonhosted.org/packages/source/h/h5netcdf/h5netcdf-$pkgver.tar.gz"
+ "https://files.pythonhosted.org/packages/source/${_pypi::1}/$_pypi/$_pypi-$pkgver.tar.gz"
)
sha256sums=(
- '6d3623f9ea46747249333792f13b515d05ff652dcec1ee436fa969bee03a8dd5'
+ '43ecc47614ae804879b51cc95d6264520fcddfe83ccfa7d92b6e236da7dc25db'
)
build() {
- cd "$srcdir/h5netcdf-${pkgver}"
+ cd "$_pypi-${pkgver}"
python setup.py build
}
check() {
- cd "$srcdir/h5netcdf-${pkgver}"
+ cd "$_pypi-${pkgver}"
PYTHONPATH="./build/lib" PYTHONDONTWRITEBYTECODE=1 pytest -v --disable-warnings
}
package() {
- cd "$srcdir/h5netcdf-${pkgver}"
+ cd "$_pypi-${pkgver}"
python setup.py install --prefix=/usr --root="$pkgdir" --skip-build --optimize 1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}