summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28af26606091..1585a080770b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-h5netcdf
pkgver=0.7.4
-pkgrel=1
+pkgrel=2
pkgdesc="Pythonic interface to netCDF4 via h5py"
arch=('any')
url="https://github.com/shoyer/h5netcdf"
@@ -10,8 +10,17 @@ license=('BSD')
depends=('python-h5py')
makedepends=('python-setuptools')
checkdepends=('python-netcdf4' 'python-pytest')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/shoyer/h5netcdf/archive/v${pkgver}.tar.gz")
-sha256sums=('9c53363f05e76a6913f259abb8013e7e6173b0e60af6455a2c1ea1750a1524e9')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/shoyer/h5netcdf/archive/v${pkgver}.tar.gz"
+ "pytest-5.patch")
+sha256sums=('9c53363f05e76a6913f259abb8013e7e6173b0e60af6455a2c1ea1750a1524e9'
+ 'e0cf10dc5faa80f5fb91f83b1a8fb434356ed187e13c554f553333c3e3e49406')
+
+prepare() {
+ cd "$srcdir/h5netcdf-${pkgver}"
+ # https://aur.archlinux.org/packages/python-h5netcdf/#comment-712212
+ # https://github.com/shoyer/h5netcdf/issues/61
+ patch --forward --strip=2 --input="${srcdir}/pytest-5.patch"
+}
build() {
cd "$srcdir/h5netcdf-${pkgver}"