summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 506fc73d0ae4..74f3753e81da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,41 +2,41 @@
_pkgname=python-hashpumpy
pkgname=$_pkgname-git
-pkgver=v1.2.0.r8.g314268e
-pkgrel=2
+pkgver=1.2.0.r8.g314268e
+pkgrel=1
pkgdesc=" A tool to exploit the hash length extension attack in various hashing algorithms"
arch=("i686" "x86_64")
url="https://github.com/bwall/HashPump"
license=('MIT')
makedepends=('git')
depends=('openssl' 'python')
-provides=("$_pkgname")
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
source=("$_pkgname"::"git+https://github.com/bwall/HashPump")
md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
- git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+ cd $_pkgname
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd "${srcdir}/${_pkgname}"
+ cd $_pkgname
python setup.py build
}
check() {
- cd "${srcdir}/${_pkgname}"
+ cd $_pkgname
- pyver=$(python -c 'import sysconfig; print(sysconfig.get_config_var("VERSION"))')
- export PYTHONPATH="$(pwd)/build/lib.linux-$CARCH-$pyver:$PYTHONPATH"
+ export PYTHONPATH="$(pwd)/build/lib.linux-$CARCH-3.7:$PYTHONPATH"
python test.py
}
package() {
- cd "${srcdir}/${_pkgname}"
- python setup.py install --skip-build --root="${pkgdir}"
+ cd $_pkgname
- install -Dm755 -d "$pkgdir/usr/share/licenses/$pkgname/"
- install -Dm644 LICENSE.TXT "$pkgdir/usr/share/licenses/$pkgname/"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ install -Dm644 LICENSE.TXT "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
}