summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c13da4e0b219..308b72e5eb8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,22 @@
# Maintainer: Jerry Lin <jerry73204 at gmail dot com>
-pkgname=('python-hbmqtt')
-pkgver=0.9.5
+pkgname='python-hbmqtt'
+pkgver=0.9.6
pkgrel=2
pkgdesc='MQTT client/broker using Python asynchronous I/O'
-arch=('x86_64')
+arch=('x86_64' 'armv7h')
url="https://github.com/beerfactory/hbmqtt"
license=('MIT')
-makedepends=('python-setuptools' 'python2-setuptools')
-depends=('python-transitions' 'python-websockets' 'python-passlib' 'python-docopt' 'python-pyyaml')
+makedepends=('python-setuptools')
+depends=(
+ 'python-transitions'
+ 'python-websockets'
+ 'python-passlib'
+ 'python-docopt'
+ 'python-yaml'
+)
source=("https://github.com/beerfactory/hbmqtt/archive/${pkgver}.tar.gz")
-sha256sums=('8afe70008fbe213ae9aff6d66d6db845b41b36d9f89f711657478ec3aa428790')
+sha256sums=('7232a4f74536ee6aed913af1dfdfb1a9c6372233c6722a610d95e179b0175e53')
_dirname="hbmqtt-${pkgver}"
@@ -20,7 +26,6 @@ build() {
}
package() {
- depends=('python' 'hbmqtt')
cd "${srcdir}/${_dirname}"
python setup.py install --root="$pkgdir" --optimize=1
}