summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..671758163467
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jerry Lin <jerry73204 at gmail dot com>
+
+pkgname=('python-hbmqtt')
+pkgver=0.9.5
+pkgrel=1
+pkgdesc='Python client for Apache Kafka'
+arch=('x86_64')
+url="https://github.com/mikeboers/PyAV/tree/master"
+license=('Apache')
+makedepends=('python-setuptools' 'python2-setuptools')
+depends=('python-transitions' 'python-websockets' 'python-passlib' 'python-docopt' 'python-pyyaml')
+source=("https://github.com/beerfactory/hbmqtt/archive/${pkgver}.tar.gz")
+sha256sums=('8afe70008fbe213ae9aff6d66d6db845b41b36d9f89f711657478ec3aa428790')
+
+_dirname="hbmqtt-${pkgver}"
+
+build() {
+ cd "${srcdir}/${_dirname}"
+ python setup.py build
+}
+
+package() {
+ depends=('python' 'hbmqtt')
+ cd "${srcdir}/${_dirname}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}