summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9eb013a61c3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+pkgname=python-healpy
+pkgver=1.11.0
+pkgrel=1
+pkgdesc="Python package to manipulate healpix maps"
+arch=('i686' 'x86_64')
+url="http://healpy.readthedocs.org"
+license=('GPL')
+depends=('python>=3.4' 'python-numpy>=1.5' 'python-matplotlib' 'python-astropy')
+source=("https://files.pythonhosted.org/packages/source/h/healpy/healpy-${pkgver}.tar.gz")
+md5sums=('c30daf225b3173224d6ea0cb10714b87')
+
+package() {
+ cd ${srcdir}/healpy-${pkgver}
+
+ install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}