summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 28 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05061d05bf84..71f4d6a9a955 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,32 @@
-# Maintainer: Markus Kaiser <markus dot kaiser at in dot tum dot de>
-_pkgname=holoviews
-pkgname=python-$_pkgname
-pkgver=1.13.2
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Markus Kaiser <markus dot kaiser at in dot tum dot de>
+_base=holoviews
+pkgname=python-${_base}
+pkgver=1.18.3
pkgrel=1
-pkgdesc="Stop plotting your data - annotate your data and let it visualize itself."
-arch=("any")
-url="http://holoviews.org"
-license=('BSD')
-depends=('python-numpy' 'python-param' 'python-pandas' 'python-panel' 'python-pyviz_comms')
-makedepends=('python-pyct')
-options=(!emptydirs)
-source=('https://files.pythonhosted.org/packages/9b/ad/aec5011cc02803e50b11c4967b1b2c2fba8c4e5e0f6f2d9f96db3e29cc3b/holoviews-1.13.2.tar.gz')
-sha256sums=('cf2dd426cdc08bf2ca669268ca0432634574429e5b143314ee06ad88c5382802')
+pkgdesc="With Holoviews, your data visualizes itself"
+arch=(any)
+url="https://${_base}.org"
+license=(BSD-3-Clause)
+depends=(python-panel python-colorcet)
+makedepends=(python-build python-installer python-wheel)
+optdepends=('jupyter-nbconvert: for use holoviews command')
+source=(${_base}-${pkgver}.tar.gz::https://github.com/holoviz/${_base}/archive/v${pkgver}.tar.gz)
+sha512sums=('85f741aeb76728cc33bee704e880b21c0b2ef7308fc63cf9e35976cbb75254d077c637c1e0ecc10f2b37661b9db30657a7c62261fb4bb897a0c00c8ba07848e3')
-package() {
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+build() {
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
-# vim:set ts=2 sw=2 et:
+package() {
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+
+ # Symlink license file
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+ ln -s "${site_packages}/${_base}-${pkgver}.dist-info/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+}