summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b2f4b295139d..479fc5cbd0e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=homeassistant-cli
pkgname=python-homeassistant-cli
-pkgver=0.5.0
+pkgver=0.6.0
pkgrel=1
pkgdesc='Command-line tool for Home Assistant'
arch=('any')
@@ -10,12 +10,12 @@ url=https://github.com/home-assistant/home-assistant-cli
license=('Apache')
depends=('python' 'python-requests' 'python-netdisco' 'python-click' 'python-click-log' 'python-tabulate' 'python-jsonpath-rw' 'python-jinja' 'python-dateparser' 'python-regex' 'python-ruamel-yaml' 'python-aiohttp' 'python-setuptools')
source=("https://files.pythonhosted.org/packages/source/h/homeassistant-cli/$_name-$pkgver.tar.gz")
-sha512sums=("9d07d0e3a7a0fae9d5d7431b18207c2ec6615bf03c6b8c8a600a0d07618ae55cebbbd49456fe702a1300a8327f0a02ee57b528fab60ec4a997f2fb5feb755526")
+sha512sums=("0d41bbde95b3e52182f5351bb9de088550251630d5688453527f175cd78e553d063d6af463de102c157fbff98c82caffa9f19921cfaa3362ed19f940d460f901")
build() {
cd $_name-$pkgver
- sed -i 's/regex==2019.01.24/regex==2019.02.06/' setup.py
- sed -i 's/ruamel.yaml==0.15.85/ruamel.yaml==0.15.87/' setup.py
+ sed -i 's/regex==2019.[0-9]\{2\}.[0-9]\{2\}/regex>=2019.02.18/' setup.py
+ sed -i 's/ruamel.yaml==0.[0-9]\{2\}.[0-9]\{2\}/ruamel.yaml>=0.15.88/' setup.py
python setup.py build
}