summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53e00e058b6b..48bad7df6863 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,16 @@
_pkgname=horovod
pkgname=python-horovod
pkgver=0.28.1
-pkgrel=2
+pkgrel=3
pkgdesc='Distributed training framework for TensorFlow, Keras, PyTorch, and Apache MXNet'
arch=('x86_64')
url='https://github.com/horovod/horovod'
-license=('Apache')
+license=('Apache-2.0')
depends=(
cuda
cudnn
+ gcc-libs
+ glibc
nccl
openmpi
python-cloudpickle
@@ -39,14 +41,17 @@ optdepends=(
'python-tensorflow-cuda: tensorflow framework'
)
source=("${_pkgname}-${pkgver}::git+https://github.com/horovod/horovod.git#tag=v${pkgver}"
- "0001.fix-building-with-torch-2.1.patch::https://github.com/horovod/horovod/pull/3998.patch"
+ "0001-fix-building-with-torch-2.1.patch::https://github.com/horovod/horovod/pull/3998.patch"
+ "0002-fix-building-torch-extension-with-glog.patch"
)
sha512sums=('SKIP'
- '32ec82943a5f96de21b11b2b994f30779d827d8a5dab380654169eebc954e0dc122333d610fc32607a8bf11dd425117d035ab1f1cb8c6a36717c3c0b89692431')
+ '7c56b56e665e0590ced4366d71dcd5ed83cab7e2943b0548d0472ef19b5a051a9dcaa8800c417882b171acbe4dc5f745e1c876aabb0bb8564215ce121f14cf67'
+ '52850f5e4f60122e0064307f0d5d5fb6781c8f77f0e54d4b9c306e98bd15d1edc1c670a1623653fb571332c74cb11d7ffd5a1b7e6fe3403f990cc96ca5ccf7c0')
prepare() {
cd "${_pkgname}-${pkgver}"
- patch -p1 -i "${srcdir}/0001.fix-building-with-torch-2.1.patch"
+ patch -p1 -i "${srcdir}/0001-fix-building-with-torch-2.1.patch"
+ patch -p1 -i "${srcdir}/0002-fix-building-torch-extension-with-glog.patch"
git submodule update --init --recursive
}
@@ -75,4 +80,3 @@ package() {
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim:set ts=2 sw=2 et:
-