summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 35 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 97f0263a325d..5b6dc4b44e76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Contributor: Tomas Ostasevicius <t dot ostasevicius at gmail dot com>
# Maintainer: Jonas Lähnemann <jonas at pdi-berlin dot de>
+# Maintainer: Joshua Taillon <jat255 AT gmail DOT com>
pkgname=python-hyperspy
pkgshort=hyperspy
pkgver=1.6.0
@@ -9,19 +10,40 @@ arch=('any')
url="http://hyperspy.org"
license=('GPL3')
-depends=('python' 'python-scipy' 'python-matplotlib' 'python-numpy'
- 'python-traits' 'python-natsort' 'python-requests' 'python-tqdm'
- 'python-sympy' 'python-dill' 'python-h5py' 'python-dateutil'
- 'python-ipyparallel' 'python-dask' 'python-scikit-image'
- 'python-pint' 'python-statsmodels' 'python-numexpr' 'python-sparse'
- 'python-imageio' 'python-pyaml' 'python-ptable' 'python-tifffile'
- 'python-numba' )
-
-optdepends=('python-scikit-learn: learning'
- 'python-hyperspy-gui-ipywidgets: gui-jupyter'
- 'python-hyperspy-gui-traitsui: gui-traitsui'
- 'python-blosc: mrcz'
- 'cython: speed' )
+depends=('python'
+ 'python-scipy'
+ 'python-matplotlib'
+ 'python-numpy'
+ 'python-traits'
+ 'python-natsort'
+ 'python-requests'
+ 'python-tqdm'
+ 'python-sympy'
+ 'python-h5py'
+ 'python-dateutil'
+ 'python-dask'
+ 'python-pint'
+ 'python-statsmodels'
+ 'python-numexpr'
+ 'python-pyaml'
+ 'python-ptable'
+ 'python-dill' # AUR
+ 'python-ipyparallel' # AUR
+ 'python-scikit-image' # AUR
+ 'python-sparse' # AUR
+ # 'python-imageio' # AUR (from scikit-image)
+ # 'python-pywavelets' # AUR (from scikit-image)
+ # 'python-tifffile' # AUR (from scikit-image)
+ # 'python-numba' # AUR (from python-sparse)
+ # 'python-llvmlite' # AUR (from python-numba)
+ 'python-llvmlite-bin' # AUR (from python-numba, but require bin package to avoid version mismatches)
+ )
+
+optdepends=('python-scikit-learn: machine learning features'
+ 'python-hyperspy-gui-ipywidgets: GUI components for Jupyter' # AUR
+ 'python-hyperspy-gui-traitsui: GUI components for desktop' # AUR
+ 'python-blosc: mrcz file support'
+ 'cython: enables acceleration of certain operations (must be installed at package build time)' )
makedepends=('python-setuptools' )