summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d338bec2aa3..a56b112c86d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname="python-imageio"
_pkgname="imageio"
pkgver=2.31.5
-pkgrel=3
+pkgrel=4
pkgdesc="a Python library that provides an easy interface to read and write a wide range of image data"
arch=('any')
_github="imageio/imageio"
@@ -12,7 +12,7 @@ url="https://github.com/imageio/imageio"
license=('BSD')
depends=('python-numpy' 'python-pillow')
optdepends=('avbin' 'python-imageio-ffmpeg' 'freeimage' 'python-astropy' 'python-simpleitk')
-makedepends=('python-build' 'python-installer' 'python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
source=("$pkgname-$pkgver.tar.gz::https://github.com/imageio/imageio/archive/v${pkgver}.tar.gz")
sha256sums=('a04e1d87e01734c8981c2989b1d2b5bd729821705b09066cfc6c31d5ffe0ffd7')
@@ -24,7 +24,7 @@ build() {
package() {
cd "$srcdir/${_pkgname}-${pkgver}"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ python -m installer --destdir="$pkgdir" --compile-bytecode=1 dist/*.whl
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
# remove utilities for downloading binary dependencies