summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da7c6efc08d7..70301e8dbdae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,24 @@
# Contributor:
pkgname=python-imageio-ffmpeg
-pkgver=0.4.3
+pkgver=0.4.9
pkgrel=1
pkgdesc="FFMPEG wrapper for Python"
arch=("any")
license=("BSD")
url="https://github.com/imageio/imageio-ffmpeg"
depends=('python' 'ffmpeg')
-makedepends=('python-setuptools')
-source=("https://github.com/imageio/imageio-ffmpeg/archive/v${pkgver}.tar.gz")
-sha256sums=('906680ae784d79972671c6a0adf5ce1604703506def9096d346f758a6a52bf6f')
+makedepends=('git' 'python-build' 'python-installer' 'python-wheel' 'python-setuptools')
+source=("git+https://github.com/imageio/imageio-ffmpeg.git#tag=v${pkgver}")
+sha256sums=('SKIP')
build() {
- cd "imageio-ffmpeg-${pkgver}"
- python setup.py build
+ cd "imageio-ffmpeg"
+ python -m build --wheel --no-isolation
}
package() {
- cd "imageio-ffmpeg-${pkgver}"
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ cd "imageio-ffmpeg"
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/python-imageio-ffmpeg/LICENSE"
}