summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 242660c497ab..e393e5156f5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,18 @@
pkgname='python-imgtool'
_name="imgtool"
pkgdesc="MCUboot's image signing and key management"
-pkgver=1.9.0
+pkgver=2.0.0
pkgrel=1
arch=('any')
url='https://pypi.org/project/imgtool/'
license=('Apache')
-depends=('python>=3.6'
- 'python-cryptography>=2.6'
- 'python-intelhex'
- 'python-click>=1.0.0')
+depends=(
+ 'python>=3.6'
+ 'python-cryptography>=2.4.2'
+ 'python-intelhex>=2.2.1'
+ 'python-cbor2'
+ 'python-click'
+)
#makedepends=()
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
@@ -25,4 +28,4 @@ package() {
python setup.py install --root="$pkgdir" --optimize=1
}
-sha256sums=('7fa7f6bd6bf069b5ffa07ea47478e16b6206bd2fc5b7607def999de0e9134a43')
+sha256sums=('7a541255e69eec1f12aa38dce1f1d4fe20d8212677c68a9b6ec634ca91a06612')