summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf522b113b92..8c85660c2942 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
pkgbase=python-iminuit
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
-pkgver=1.5.4
+pkgver=2.0.0
pkgrel=1
pkgdesc="Python interface for MINUIT, a physics analysis tool for function minimization."
arch=('i686' 'x86_64')
url="http://iminuit.readthedocs.io"
license=('GPL' 'MIT')
-makedepends=('cython' 'python-numpy')
+makedepends=('python-setuptools' 'python-numpy' 'cmake')
checkdepends=('python-pytest')
options=(!emptydirs)
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('9090d7599c2d8404aa2fb5b6ec1fad41')
+md5sums=('42f28d997784b7f85e3cdda03041e5cf')
prepare() {
export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
@@ -30,7 +30,7 @@ check() {
}
package_python-iminuit() {
- depends=('python>=3.5' 'python-numpy>=1.11.3')
+ depends=('python>=3.6' 'python-numpy')
optdepends=('ipython'
'python-matplotlib'
'python-pytest-cov: For testing and get a coverage report'