summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7f29f4a1a074..1ee6e389db08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,20 +6,21 @@ _base=imutils
pkgname=python-${_base}
pkgdesc="A series of convenience functions to make basic image processing asier with OpenCV"
pkgver=0.5.4
-pkgrel=2
+pkgrel=3
arch=(any)
url="https://github.com/jrosebr1/${_base}"
license=(MIT)
depends=(python-opencv hdf5)
+makedepends=(python-build python-installer python-setuptools python-wheel)
source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
sha512sums=('50f9b43842cac55055a94d277fea958b8593bbc9b249878cc7e545368220667cb853d059c9ea412d034220c240343fe5e009e407554a10da958822d6e7e30728')
build() {
cd ${_base}-${pkgver}
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
cd ${_base}-${pkgver}
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
}