summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b97c6630745b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Sophie Tauchert <sophie@999eagle.moe>
+
+_pkgname=injector
+pkgname=python-${_pkgname}
+pkgver=0.14.1
+pkgrel=1
+pkgdesc="Python dependency injection framework, inspired by Guice."
+arch=('any')
+url="http://github.com/alecthomas/injector"
+license=('BSD')
+depends=()
+makedepends=('python-setuptools')
+provides=()
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('1413e2b1dd90c594689bc292bcc02628b969840c1292131455927f292c65e99a')
+
+build() {
+ cd "${_pkgname}-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}