summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b97c6630745b..f2c946ddb2ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,18 @@
_pkgname=injector
pkgname=python-${_pkgname}
pkgver=0.14.1
-pkgrel=1
+pkgrel=2
pkgdesc="Python dependency injection framework, inspired by Guice."
arch=('any')
url="http://github.com/alecthomas/injector"
license=('BSD')
-depends=()
+depends=('python')
makedepends=('python-setuptools')
provides=()
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('1413e2b1dd90c594689bc292bcc02628b969840c1292131455927f292c65e99a')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/alecthomas/injector/${pkgver}/COPYING")
+sha256sums=('1413e2b1dd90c594689bc292bcc02628b969840c1292131455927f292c65e99a'
+ '567278bc23fa55244f132af7164aa684940c75fa35b19c395899422cb92613ba')
build() {
cd "${_pkgname}-$pkgver"
@@ -20,6 +22,7 @@ build() {
}
package() {
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd "${_pkgname}-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}