summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7912bb5e449f..d07716e7c25f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrej Radović <r.andrej@gmail.com>
pkgname=python-inventree
_name=${pkgname#python-}
-pkgver=0.10.0
+pkgver=0.11.2
pkgrel=1
pkgdesc="Python interface for InvenTree inventory management system"
url="https://github.com/inventree/inventree-python/"
@@ -9,20 +9,20 @@ depends=(
'python'
'python-requests'
)
-makedepends=('python-setuptools')
+makedepends=(python-build python-installer python-wheel)
license=('GPL3')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('cbd099b254168cb38eed5d614626d592d427fba43ffca1cc8e7bfcfadbb6f418')
+sha256sums=('fd4eeb03b871b10da578c092cf1e5acb30d60afeb9390885def1c38c0cc109a0')
build() {
cd "$srcdir/$_name-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
cd $pkgdir/usr/lib/python3*/site-packages/
rm -rf scripts test
}